Fluid support for PHPStorm and IntelliJ

Quantity Unit price
To 5 €19.99 *
From 6 €17.99 *
From 20 €16.99 *
From 50 €15.99 *

Prices incl. VAT

Available as instant download

Update Subscription period:

Fluid Plugin - Defines the access period for current updates. You can always use the latest available version from your period.

  • SG10010002.5
No bundles available for the selected variant. Please select another variant for bundle offers.
Save money with our bundle offer:
TypoScript support for PHPStorm, Webstorm and IntelliJ
Fluid support for PHPStorm and IntelliJ
€33.98 * Instead of €39.98 *
Price for all:

Open bundle

An error occurred while saving the bundle configuration.
1x TypoScript support for PHPStorm, Webstorm and IntelliJ
- sgalinski Internet Services -   €19.99 *
1x Fluid support for PHPStorm and IntelliJ
- sgalinski Internet Services -   €19.99 *
Current Version: 1.4 To support your regular work on Fluid templates, we created this plugin... more
Product information "Fluid support for PHPStorm and IntelliJ"

Current Version: 1.4

To support your regular work on Fluid templates, we created this plugin for the popular IntelliJ IDEs from Jetbrains. Please note that the Fluid plugin requires the PHP IDE plugin.

The current core features

  • Auto completion for Fluid Layouts, Partials, Sections, ViewHelpers, inline ViewHelpers, ViewHelper arguments and most of the controller view parameters
  • Quick documentation for Fluid ViewHelpers, inline ViewHelpers and the ViewHelper arguments
  • Jumping to the specific files: To the Partials, Layout, Sections within the Layout, controller by clicking on the controller view parameters, ViewHelper, inline ViewHelpers and ViewHelper arguments
  • Code highlighting for inline ViewHelpers
  • Error detection for inline ViewHelpers
  • Possible error annotations for inline ViewHelpers and ViewHelper usages
  • Brace matching for inline ViewHelpers

Subscription model

By purchasing this product, you will receive the Fluid plugin for IntelliJ in its current version, as well as all regular updates during the period declared in your subscription. You will receive no more updates after your subscription expired, but will still be able to use the plugin at the current version of the date of expiration.

Frequently Asked Questions

1. Can I use this licence on multiple devices?

Sure! The licence itself is bound to an user and can be used on as much devices as you want.

2. Where can I report problems and feature requests?

You can report all problems and feature requests on our Gitlab project. For support questions you can use our mail address support@sgalinski.de.

3. Why don't I get a download button in my view after I ordered with paying by invoice?

You get the download option after your payment was sucessfully transfered to our bank account.

4. How can I retrieve updates?

You can download the latest version always in your "Instant Downloads" section of your shopware account. The latest version depends on your subscription period. Note that we will remove the download possibility if the subscription period ends.

5. What means the subscription option "lifetime"?

You will get the licence and all updates for the whole product life cycle. The product support can be cancelled anytime, but we want to support it at least for five years beginning with the first version of the product.

6. Which version are supported?

Currently the minimum build number support is 143. The current supported versions are IntelliJ IDEA Ultimate 15, PhpStorm 10, IntelliJ IDEA Ultimate 2016.1, PhpStorm 2016.1, IntelliJ IDEA Ultimate 2016.2, PhpStorm 2016.2, PhpStorm 2016.3 Newer versions are usually compatible.

Further Information

Learn more about the plugin on our dedicated product page (german).

See the plugin in action:

Related links to "Fluid support for PHPStorm and IntelliJ"
Read, write and discuss reviews... more
Customer evaluation for "Fluid support for PHPStorm and IntelliJ"
Write an evaluation
Evaluations will be activated after verification.
Please enter these characters in the following text field.

The fields marked with * are required.